Share: Email | Twitter

ID

VDE-2021-060

Published

2022-01-05 08:00 (CET)

Last update

2022-02-09 10:20 (CET)

Vendor(s)

WAGO GmbH & Co. KG

Product(s)

Article No┬░ Product Name Affected Version(s)
- WAGO Smart Script 4.2 < 4.8.1.4

Summary

Apache Log4j is used for logging events in WAGO Smart Script in Version 4.2 and higher.  Events logged by Log4j can contain JNDI references. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. Additionally, Log4j does not protect from self-referential lookups, which can lead to Denial of Service.

UPDATE A1/2: 
Affected versions:

CVE-2021-44228 and CVE-2021-45046:
WAGO Smart Script >= Version 4.2 and < Version 4.8.1.3

CVE-2021-45105:
WAGO Smart Script >= Version 4.2 and < Version 4.8.1.4

CVE-2021-44832
WAGO Smart Script >= Version 4.2 and < Version 4.8.1.5

END UPDATE A1/2

Vulnerabilities



Weakness
Uncontrolled Resource Consumption (CWE-400)
Summary

Apache Log4j2 2.0-beta9 through 2.12.1 and 2.13.0 through 2.15.0 JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. ...

Weakness
Deserialization of Untrusted Data (CWE-502)
Summary

It was found that the fix to address CVE-2021-44228 in Apache Log4j 2.15.0 was incomplete in certain non-default configurations. This could allows attackers with control over Thread Context Map (MDC) ...

Weakness
Improper Input Validation (CWE-20)
Summary

Apache Log4j2 versions 2.0-beta7 through 2.17.0 (excluding security fix releases 2.3.2 and 2.12.4) are vulnerable to a remote code execution (RCE) attack when a configuration uses a JDBC Appender with ...

Weakness
Improper Input Validation (CWE-20)
Summary

Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3 and 2.3.1) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data ...

Impact

Log Messages controlled by an attacker could lead to remote code execution. Additionally, Log4j does not protect from self-referential lookups, which can lead to Denial of Service.

Solution

Mitigation

Do not use projects from untrusted sources.

For further impact information and risk mitigation, see the recommendations of the

Solution

UPDATE A2/2:
Install Version 4.8.1.5 or later of WAGO Smart Script, which is available on our Website.
Customers using Version 4.6 or higher can already use the integrated “Check for update” function of WAGO Smart Script to update to Version 4.8.1.5.
END UPDATE A2/2

Reported by

CERT@VDE coordinated with WAGO